Home/Network & Accessories/Routers/TP-LINK ARCHER VR900 V2 AC1900 Wireless Gigabit VD...
TP-LINK ARCHER VR900 V2 AC1900 Wireless Gigabit VDSL/ADSL Modem Router

TP-LINK ARCHER VR900 V2 AC1900 Wireless Gigabit VDSL/ADSL Modem Router

SKU ARCHER VR900 V2
TP-LINKShop all TP-LINK parts (491) ›
  • Versatile Connectivity – Ethernet WAN and USB ports, the VR900 is fully compatible with VDSL2/ADSL2+/ADSL2/ADSL standard, fibre/cable access and 3G/4G USB dongles
  • Superfast Wi-Fi – 600Mbps on 2.4GHz + 1300Mbps on 5GHz
  • Maximum Range – 3 dual band detachable antennas provide maximum Omni-directional wireless coverage and reliability
  • 1GHz Dual-core Processor – Ensures no interruption while processing multiple wired or wireless tasks simultaneously
  • Beamforming Technology – Improves wireless range and performance on both 2.4GHz and 5GHz band
Available to order

ARCHER VR900 V2 isn't on our shelf today — we source it to order. Request a quote and we'll confirm price and lead time within one business day.

Key specifications

See full specs ↓
Ethernet WAN
Yes
DSL WAN
Yes
SIM card slot
No
3G/4G USB modem compatibility
Yes
WAN connection type
RJ-45
Wi-Fi band
Dual-band (2.4 GHz / 5 GHz)

Product details

TP-Link AC1900 Wireless Gigabit VDSL/ADSL Modem Router. WAN connection type: RJ-45. Wi-Fi band: Dual-band (2.4 GHz / 5 GHz), Top Wi-Fi standard: Wi-Fi 5 (802.11ac), WLAN data transfer rate (max): 1300 Mbit/s. Ethernet LAN interface type: Gigabit Ethernet, Ethernet LAN data rates: 10,100,1000 Mbit/s, Cabling technology: 10/100/1000Base-T(X). Security algorithms: 128-bit WEP, 64-bit WEP, WPA, WPA-PSK, WPA2, WPA2-PSK. Management protocols: SSL for TR-069, SNMP v1/2c, Data link protocols: IPv4, IPv6, Supported network protocols: ATM Forum UNI3.1/4.0, PPP over ATM (RFC 2364), PPP over Ethernet (RFC2516), IPoA (RFC1577/2225),...

Specifications

Ethernet WAN
Yes
DSL WAN
Yes
SIM card slot
No
3G/4G USB modem compatibility
Yes
WAN connection type
RJ-45
Wi-Fi band
Dual-band (2.4 GHz / 5 GHz)
Top Wi-Fi standard
Wi-Fi 5 (802.11ac)
WLAN data transfer rate (max)
1300 Mbit/s
Wi-Fi standards
802.11a, Wi-Fi 5 (802.11ac), 802.11b, 802.11g, Wi-Fi 4 (802.11n)
WLAN data transfer rate (first band)
1300 Mbit/s
WLAN data transfer rate (second band)
600 Mbit/s
Ethernet LAN
Yes
Ethernet LAN interface type
Gigabit Ethernet
Ethernet LAN data rates
10,100,1000 Mbit/s
Cabling technology
10/100/1000Base-T(X)
Networking standards
IEEE 802.11a, IEEE 802.11ac, IEEE 802.11b, IEEE 802.11g, IEEE 802.11n, IEEE 802.3, IEEE 802.3ab, IEEE 802.3u
Dynamic DNS (DDNS)
Yes
Static route
Yes
VPN tunnels quantity
10
VPN Passthrough
Yes
VPN support
PPTP, L2TP, IPSec Passthrough
ADSL
Yes
ADSL2
Yes
ADSL2+
Yes
VDSL2
Yes
Ethernet LAN (RJ-45) ports
4
USB port
Yes
USB 3.2 Gen 1 (3.1 Gen 1) Type-A ports quantity
2
RJ-11 ports quantity
1
DC-in jack
Yes
Web-based management
Yes
Quality of Service (QoS) support
Yes
Reset button
Yes
WPS push button
Yes
Security algorithms
128-bit WEP, 64-bit WEP, WPA, WPA-PSK, WPA2, WPA2-PSK
Firewall
Yes
Guest access
Yes
Access Control List (ACL)
Yes
DoS attack prevention
Yes
Filtering
Yes
MAC address filtering
Yes
IP address filtering
Yes
URL filtering
Yes
DHCP client
Yes
DHCP server
Yes
Universal Plug and Play (UPnP)
Yes
Management protocols
SSL for TR-069, SNMP v1/2c
Data link protocols
IPv4, IPv6
Supported network protocols
ATM Forum UNI3.1/4.0, PPP over ATM (RFC 2364), PPP over Ethernet (RFC2516), IPoA (RFC1577/2225), MER\IPoE (RFC 1483 Routed), Bridge (RFC1483 Bridge), PVC
Product colour
White
Wall mountable
Yes
Indication light
Yes
LED indicators
Yes
On/off switch
Yes
Product type
Tabletop router
Certification
CE, RCM, RoHS
Cables included
DSL, LAN (RJ-45), Phone (RJ-11)
AC adapter included
Yes
Quick installation guide
Yes
Antenna design
External
Antenna connector type
RP-SMA
Antenna gain level (max)
3 dBi
Antennas quantity
3
Detachable antenna(s)
Yes
Transmit power
0 dBmW
Power source type
AC
Output voltage
12 V
Output current
2.5 A
Operating temperature (T-T)
0 - 40 °C
Storage temperature (T-T)
-40 - 70 °C
Operating relative humidity (H-H)
10 - 90%
Storage relative humidity (H-H)
5 - 90%
Windows operating systems supported
Windows 2000, Windows 2000 Professional, Windows 7 Home Premium, Windows 7 Home Premium x64, Windows 7 Professional, Windows 7 Professional x64, Windows 7 Starter, Windows 7 Starter x64, Windows 7 Ultimate, Windows 7 Ultimate x64, Windows 8, Windows 8 Enterprise, Windows 8 Enterprise x64, Windows 8 Pro, Windows 8 Pro x64, Windows 8 x64, Windows 8.1, Windows 8.1 Enterprise, Windows 8.1 Enterprise x64, Windows 8.1 Pro, Windows 8.1 Pro x64, Windows 8.1 x64, Windows 98SE, Windows NT, Windows Vista Business, Windows Vista Business x64, Windows Vista Enterprise, Windows Vista Enterprise x64, Windows Vista Home Basic, Windows Vista Home Basic x64, Windows Vista Home Premium, Windows Vista Home Premium x64, Windows Vista Ultimate, Windows Vista Ultimate x64, Windows XP Home, Windows XP Home x64, Windows XP Professional, Windows XP Professional x64
Linux operating systems supported
Yes
Mac operating systems supported
macOS
Width
215.7 mm
Depth
163.7 mm
Height
38.9 mm
Package width
318 mm
Package depth
240 mm

Description

VDSL with 1.9Gbps Wi-Fi The Ultimate Buffer Breaker AC 1900 Wireless Gigabit VDSL/ADSL Modem Router Hop on the Internet Fast Lane with 1.9Gbps Wi-Fi The Archer VR900 makes full use of its dual band Wi-Fi abilities, reaching speeds of up to 600Mbps on the 2.4GHz band and 1300Mbps on the 5GHz band. Enjoy a total speed of up to 1.9Gbps to eliminate buffering from your HD streams and lag from online games. The two wireless bands are separated in two dedicated Wi-Fi networks, supporting more devices while reducing signal interference, to deliver a stable connection for every wireless device in your home. Breaking VDSL Broadband Speeds Replace both your last-gen modem and Wi-Fi router with The Archer VR900, a two-in one advanced machine. Built with advanced VDSL2 technology, it delivers broadband speeds of up to 100Mbps, almost five times faster than the previous ADSL2+. In case you don’t have VDSL2 yet, an integrated DSL port supports all standard DSL connections, including VDSL2, ADSL2+, ADSL2, ADSL. Diverse Connections The Archer VR900 is built to connect you to the internet, no matter your situation. The Ethernet WAN port supports wired connections to cable and fibre modems, letting you take full charge of its wireless capabilities as a router. In case your internet goes down, attach a 3G/4G adapter to two USB 3.0 ports to serve as a backup option so you can get back online in no time. Better Coverage and a More Stable Connection With three external antennas, the Archer VR900 provides stable coverage throughout your entire home or office. Advanced beamforming technology automatically locates wireless devices and forms targeted, highly efficient wireless connections to them, even as they move from room to room. One Powerful Processor The 1GHz dual-core Broadcom processor with 2 co-processors boost data transfer speeds and ensures that performance is never compromised, even while simultaneously processing multiple wireless and wired tasks. This processor is equipped to handle your busy network while you enjoy a hassle-free, connected life. Lightning-Fast Wired Connection The Archer VR900's dual USB 3.0 ports run 10x faster than USB 2.0 for data transfer at lightning speed. Connect external drives and easily share files, photos, music and video across your network. To help your wired devices achieve peak performance, the Archer VR900 is also equipped with four Gigabit Ethernet ports that can operate 10x faster than standard Ethernet. An Appealing Aesthetic The Archer VR900 is designed as a welcome addition your modern home. A glossy black finish of makes it fit the decor of any bedroom or common space. Silver accents provide an aura of elegance, making the Archer VR900 easy to display atop a table or mounted on the wall. For added convenience, you can easily disable the LED indicators to prevent distractions at night. Easy Setup and Use An intuitive, multilingual web interface (currently available in English, German, French, Italian, Polish and Turkish) makes PC setup of the Archer VR900 easier than ever before. We also provide a new mobile interface for your convenience. Put control at your fingertips with Tether, an app that lets you manage network settings - including parental controls and media sharing - from any Android or iOS device.

Condition: Refurbished

Free U.S. ground shipping

Typically 1–2 days handling, 3–7 days in transit.

Purchase orders accepted

Government, enterprise, data center and small business.

Warranty & RMA support

See warranty and returns.

Volume pricing

Buying 10+ units?

Get volume pricing and availability for ARCHER VR900 V2.

Questions about this part?

Compatibility, condition, lead times — ask a specialist.

(888) 988-8093

Related products

Loading related inventory…