Home/Network & Accessories/Network Switches/Allied Telesis AT-FS750/28PS-30 FS750 Series 24 x ...
Allied Telesis AT-FS750/28PS-30 FS750 Series 24 x Ports 10/100Base-TX PoE + 2 x Ports 1000Base-T + 2...

Allied Telesis AT-FS750/28PS-30 FS750 Series 24 x Ports 10/100Base-TX PoE + 2 x Ports 1000Base-T + 2...

SKU AT-FS750/28PS-30
Allied TelesisShop all Allied Telesis parts (589) ›
  • Managed Web-based management SNMPv1/v2c/v3
  • Quality of Service (QoS) support
  • Basic switching RJ-45 Ethernet ports quantity: 26
  • 10BASE-T, 100BASE-TX, 100BASE-T, 1000BASE-T
  • 200 Access Control List (ACL)
  • 1U Rack mounting
  • Power supply included Power over Ethernet (PoE)
Available to order

AT-FS750/28PS-30 isn't on our shelf today — we source it to order. Request a quote and we'll confirm price and lead time within one business day.

Key specifications

See full specs ↓
Switch type
Managed
Quality of Service (QoS) support
Yes
Web-based management
Yes
System event log
Yes
MIB support
RFC 1213 MIB-II, RFC 1643 Ethernet MIB, RFC 1493 Bridge MIB, RFC 2131 DHCP client, Private Enterprise MIB
Basic switching RJ-45 Ethernet ports quantity
26

Product details

Allied Telesis AT-FS750/28PS-30. Switch type: Managed. Basic switching RJ-45 Ethernet ports type: Fast Ethernet (10/100), Basic switching RJ-45 Ethernet ports quantity: 26. MAC address table: 8000 entries, Switching capacity: 12.8 Gbit/s. Networking standards: IEEE 802.1D, IEEE 802.1Q, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3, IEEE.... Power over Ethernet (PoE). Wall mountable, Rack mounting, Form factor: 1U

Specifications

Switch type
Managed
Quality of Service (QoS) support
Yes
Web-based management
Yes
System event log
Yes
MIB support
RFC 1213 MIB-II, RFC 1643 Ethernet MIB, RFC 1493 Bridge MIB, RFC 2131 DHCP client, Private Enterprise MIB
Basic switching RJ-45 Ethernet ports quantity
26
Basic switching RJ-45 Ethernet ports type
Fast Ethernet (10/100)
Fast Ethernet (copper) ports quantity
24
Gigabit Ethernet (copper) ports quantity
2
Combo SFP ports quantity
2
Fiber optic connector
SFP
Networking standards
IEEE 802.1D, IEEE 802.1Q, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z
10G support
No
Copper ethernet cabling technology
10BASE-T, 100BASE-TX, 100BASE-T, 1000BASE-T
Port mirroring
Yes
Flow control support
Yes
Link aggregation
Yes
Broadcast storm control
Yes
Rate limiting
Yes
Spanning tree protocol
Yes
Head-of-line (HOL) blocking
Yes
VLAN support
Yes
Virtual LAN features
VLAN Identifier ( VLAN ID), Tagged VLAN, Port-based VLAN
Number of VLANs
256
Switching capacity
12.8 Gbit/s
Forwarding rate
9.5 Mpps
MAC address table
8000 entries
Number of queues
4
Jumbo frames support
Yes
Jumbo frames
10000
Packet buffer memory
4.1 MB
DHCP features
DHCP client
Access Control List (ACL)
Yes
Access Control List (ACL) rules
200
IGMP snooping
Yes
Security algorithms
802.1x RADIUS, SNMPv3
MAC address filtering
Yes
Authentication
MAC-based authentication, Port-based authentication
Password protection
Yes
Authentication type
RADIUS
Multicast support
Yes
Number of multicast groups filtered
256
Management protocols
SNMPv1/v2c/v3
Rack mounting
Yes
Form factor
1U
Product colour
Grey
LED indicators
Yes
Wall mountable
Yes
Memory type
DRAM
Internal memory
128 MB
Flash memory
16 MB
Firmware upgradeable
Yes
Power supply included
Yes
AC input voltage
100 - 240 V
AC input frequency
50 - 60 Hz
Power consumption (max)
241 W
Power over Ethernet (PoE)
Yes
Power over Ethernet (PoE) ports quantity
24
Power over Ethernet plus (PoE+) ports quantity
4
Total Power over Ethernet (PoE) budget
193 W
Operating temperature (T-T)
0 - 40 °C
Storage temperature (T-T)
-25 - 70 °C
Operating relative humidity (H-H)
5 - 90%
Storage relative humidity (H-H)
5 - 95%
Width
440 mm
Depth
210 mm
Height
44 mm
Manual
Yes
Rack mount kit
Yes
Certification
UL60950-1 2nd edition (UL) FCC/EN55022/CISPR 22 Class A VCCI Class A C-Tick EN60950 (TUV) EN55024 CE Mark CSA / cUL

Description

Fast Ethernet WebSmart Switch The Allied Telesis FS750/28PS WebSmart network switch features PoE+ for connectivity with security cameras, VoIP phones, RFID readers, and wireless access points. The FS750PS Series is a cost effective solution for SMB, retail stores, and at the edge of the network.

Condition: Refurbished

Free U.S. ground shipping

Typically 1–2 days handling, 3–7 days in transit.

Purchase orders accepted

Government, enterprise, data center and small business.

Warranty & RMA support

See warranty and returns.

Volume pricing

Buying 10+ units?

Get volume pricing and availability for AT-FS750/28PS-30.

Questions about this part?

Compatibility, condition, lead times — ask a specialist.

(888) 988-8093

Related products

Loading related inventory…