
Allied Telesis AT-FS750/28-50 FS750 Series 24 x Ports 10/100Base-TX + 2 x Ports 1000Base-T + 2 x Por...
- Managed Web-based management
- Quality of Service (QoS) support
- Basic switching RJ-45 Ethernet ports quantity: 28
- Access Control List (ACL)
- 1U Rack mounting
AT-FS750/28-50 isn't on our shelf today — we source it to order. Request a quote and we'll confirm price and lead time within one business day.
Key specifications
See full specs ↓- Switch type
- Managed
- Quality of Service (QoS) support
- Yes
- Web-based management
- Yes
- System event log
- Yes
- MIB support
- RFC 1213 MIB-II, RFC 1643 Ethernet MIB, RFC 1493 Bridge MIB, RFC 2131 DHCP client, Private Enterprise MIB
- Basic switching RJ-45 Ethernet ports quantity
- 28
Documents
Product details
Allied Telesis AT-FS750/28-50. Switch type: Managed. Basic switching RJ-45 Ethernet ports type: Fast Ethernet (10/100), Basic switching RJ-45 Ethernet ports quantity: 28. MAC address table: 8000 entries, Switching capacity: 12.8 Gbit/s. Networking standards: IEEE 802.11d, IEEE 802.1Q, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ad, IEEE.... Rack mounting, Form factor: 1U
Specifications
- Switch type
- Managed
- Quality of Service (QoS) support
- Yes
- Web-based management
- Yes
- System event log
- Yes
- MIB support
- RFC 1213 MIB-II, RFC 1643 Ethernet MIB, RFC 1493 Bridge MIB, RFC 2131 DHCP client, Private Enterprise MIB
- Basic switching RJ-45 Ethernet ports quantity
- 28
- Basic switching RJ-45 Ethernet ports type
- Fast Ethernet (10/100)
- Fast Ethernet (copper) ports quantity
- 24
- Gigabit Ethernet (copper) ports quantity
- 2
- Combo SFP ports quantity
- 2
- Networking standards
- IEEE 802.11d, IEEE 802.1Q, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z
- 10G support
- No
- Port mirroring
- Yes
- Flow control support
- Yes
- Link aggregation
- Yes
- Broadcast storm control
- Yes
- Rate limiting
- Yes
- Spanning tree protocol
- Yes
- Head-of-line (HOL) blocking
- Yes
- Virtual LAN features
- Tagged VLAN, Port-based VLAN
- Switching capacity
- 12.8 Gbit/s
- MAC address table
- 8000 entries
- Number of queues
- 4
- Jumbo frames support
- Yes
- Packet forwarding rate (1 Gbps)
- 1488000 pps
- Packet forwarding rate (100 Mbps)
- 148800 pps
- Packet forwarding rate (10 Mbps)
- 14880 pps
- DHCP features
- DHCP client
- Access Control List (ACL)
- Yes
- IGMP snooping
- Yes
- MAC address filtering
- Yes
- Authentication
- MAC-based authentication
- Multicast support
- Yes
- Number of multicast groups filtered
- 256
- Rack mounting
- Yes
- Form factor
- 1U
- Product colour
- Grey
- AC input voltage
- 100 - 240 V
- AC input frequency
- 50 - 60 Hz
- Power consumption (max)
- 8.7 W
- Power over Ethernet (PoE)
- No
- Operating temperature (T-T)
- 0 - 40 °C
- Width
- 330 mm
- Depth
- 18 mm
- Height
- 44 mm
- Cables included
- AC
- Harmonized System (HS) code
- 85176990
Description
These advanced Allied Telesis WebSmart switches integrate the simplicity of unmanaged switches with the performance and reliability of managed switches to provide a cost-effective, yet secure and reliable, solution for users to integrate management at the edge of their networks. With user-friendly web-based management, the FS750 Series is an ideal option for integrating simple management and security into a network solution.
Condition: Refurbished
Free U.S. ground shipping
Typically 1–2 days handling, 3–7 days in transit.
Purchase orders accepted
Government, enterprise, data center and small business.
Buying 10+ units?
Get volume pricing and availability for AT-FS750/28-50.






