Home/Network & Accessories/Network Switches/GS752TPSB-100NAS - Netgear 48-Port x 10/100/1000 R...
GS752TPSB-100NAS - Netgear 48-Port x 10/100/1000 Rack-Mountable Managed Stackable Gigabit Ethernet Switch

GS752TPSB-100NAS - Netgear 48-Port x 10/100/1000 Rack-Mountable Managed Stackable Gigabit Ethernet Switch

SKU GS752TPSB-100NAS
NetgearShop all Netgear parts (1,265) ›
  • Managed L3 Web-based management
  • Quality of Service (QoS) support
  • Basic switching RJ-45 Ethernet ports quantity: 48
  • 10G support 1000BASE-T, 1000BASE-TX, 100BASE-TX, 10BASE-T
  • Access Control List (ACL)
  • 1U Rack mounting Stackable
  • Power over Ethernet (PoE)
Available to order

Request a price for GS752TPSB-100NAS — we confirm current pricing and lead time within one business day.

Key specifications

See full specs ↓
Switch type
Managed
Switch layer
L3
Quality of Service (QoS) support
Yes
Web-based management
Yes
MIB support
RFC 1213 MIB II, RFC 1643 Ethernet Interface MIB, RFC 1493 Bridge MIB
Basic switching RJ-45 Ethernet ports quantity
48

Product details

NETGEAR 52-Port PoE Gigabit Stackable Smart Switch (GS752TPSB). Switch type: Managed, Switch layer: L3. Basic switching RJ-45 Ethernet ports quantity: 48. Full duplex, Networking standards: IEEE 802.3, IEEE 802.3ab, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x, IEEE.... Power over Ethernet (PoE). Rack mounting, Form factor: 1U

Specifications

Switch type
Managed
Switch layer
L3
Quality of Service (QoS) support
Yes
Web-based management
Yes
MIB support
RFC 1213 MIB II, RFC 1643 Ethernet Interface MIB, RFC 1493 Bridge MIB
Basic switching RJ-45 Ethernet ports quantity
48
Gigabit Ethernet (copper) ports quantity
2
SFP/SFP+ slots quantity
4
SFP module slots quantity
4
Networking standards
IEEE 802.3, IEEE 802.3ab, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z
10G support
Yes
Copper ethernet cabling technology
1000BASE-T, 1000BASE-TX, 100BASE-TX, 10BASE-T
Port mirroring
Yes
Full duplex
Yes
Ethernet LAN data rates
10,100,1000 Mbit/s
VLAN support
Yes
Number of VLANs
4093
Fiber type
Single-mode
Supported data transfer rates
10/100/1000Mbps
Store-and-forward
Yes
Number of static routes
32
Maximum data transfer rate
10 Gbit/s
Packet buffer memory
2 MB
DHCP features
DHCP client
Access Control List (ACL)
Yes
IGMP snooping
Yes
SSH/SSL support
Yes
Multicast support
Yes
Rack mounting
Yes
Stackable
Yes
Form factor
1U
Product colour
Stainless steel
LED indicators
LAN, PoE, Power, Status
Safety
CE mark, commercial, CUL 60950 (Listed)/EN 60950 (Low Voltage Directive), CB, CCC
Memory type
DDR-SDRAM
Internal memory
128 MB
Flash memory
32 MB
Firmware upgradeable
Yes
Mean time between failures (MTBF)
206539.3 h
AC input voltage
100 - 240 V
AC input frequency
50 - 60 Hz
Input current
8 A
Power consumption (typical)
526.8 W
Power over Ethernet (PoE)
Yes
Latency
20
Connectivity technology
Wired
Bandwidth
104 Gbit/s
Wi-Fi
No
Power LED
Yes
Ethernet LAN
Yes
Ethernet interface type
Fast Ethernet, Gigabit Ethernet
Operating temperature (T-T)
0 - 50 °C
Storage temperature (T-T)
-20 - 70 °C
Operating relative humidity (H-H)
10 - 90%
Storage relative humidity (H-H)
5 - 95%
Width
440 mm
Depth
310 mm
Height
43 mm
User guide
Yes
Manual
Yes
Certification
CE mark, commercial, FCC Part 15 Class A, VCCI Class A, EN 55022 (CISPR 22), EN 55024 (CISPR 24), C-Tick, CCC

Description

Enhanced Scalability and Network Convergence for Growing Businesses. The ProSafe Gigabit Stackable Smart Switch family is unique in delivering the scalability, reliability, and performance growing small and medium-sized businesses need in an affordable and easy-to-manage package. The NETGEAR’s Second Generation of these Stackable Smart Switches consists of 4 models in 28/52-port configuration with or without PoE option. They come with more port density and a total of 6 SFP ports for fiber connectivity. Among them, 2 are shared, and the other 4 are dedicated for either stacking or uplinks. This new generation of Stackable Smart Switches offers more flexibility and scalability that will make it easier and non-interruptive for growing businesses to expand their network capacity. Stacking for Scalability and High Availability. The new Generation of Stackable Smart Switches use 2 dedicated ports in the front of the switch for stacking, providing a 10Gbps, dual-ring, highly redundant stacking bus that carries intra-stack traffic and provide highest level of resilience, allowing you to stack up to six switches or up to 300 10/100/1000 Mbps ports, forming a virtual chassis for easy management under a single IP address. This stacking technology also provides several high-availability features to ensure business continuity: - Resiliency: Due to redundant stacking port connections, there is an automatic fail-over in case any switch in the stack fails, with rapid reconfiguration, thus preventing network downtime. - Hot-swappable: All switches in the stack are hot-swappable, and can be integrated or removed without disrupting the network. All switches in the stack are hot-swappable, and can be integrated or removed without disrupting the network. These Stackable Smart Switches come with a complete suite of advanced features for more robust security, higher quality of service and high availability. This switch is equipped with highly advanced features such as access control lists (ACL), static routing, rate limiting, IGMP snooping, and Dynamic VLAN assignment among others to provide a small and medium sized business with a network that is geared for growth while providing scalability and reliability. Advanced Security. These switches also provide advanced features that provide more robust security to SMBs. These include: - 802.1x for authentication. - ACL filtering to permit or deny traffic based on MAC and/or IP addresses. Advanced Quality of Service (QoS). Priority queuing ensures high-priority traffic gets delivered efficiently, even during congestion from high traffic bursts. Companies implementing network telephony or video conferencing, for example, need to be able to prioritize such voice and video traffic and other real-time applications over less latency-sensitive traffic to ensure reliability and quality. The ability to prioritize traffic ensures quality of latency-sensitive services and applications despite increasing traffic loads. Friendly to converged network with voice and video, the Stackable Smart Switches offers Auto Voice and Auto Video features that automatically configures QoS, Security and VLAN settings for IP phones and IP cameras. IPv6 Support. IGMP filtering and querier ensure multicast streams are only delivered to interested receivers, preventing flooding even without a dedicated multicast router. When receivers are in different VLANs, Multicast VLAN registration (MVR) uses a dedicated multicast VLAN to forward multicast streams and avoid duplication for clients in different VLANs. Manageability and Support. There are various easy and convenient ways to manage the Stackable Smart Switch. The new Stackable Smart Switches can be managed by the Smart Control Center software which comes free with the switch. With it, you can discover and manage all Netgear Smart Switches from a central location, conduct mass configuration and firmware upgrade. If you have other Netgear business products in your network, you can also use the NMS200, Netgear’s management platform for discovery and configuration of all your Netgear products in the network. For the peace of mind, these Stackable Smart Switches are backed by the NETGEAR ProSafe Lifetime Hardware Warranty and 1-year free 24x7 Advanced Technical Support.

Condition: Refurbished

Free U.S. ground shipping

Typically 1–2 days handling, 3–7 days in transit.

Purchase orders accepted

Government, enterprise, data center and small business.

Warranty & RMA support

See warranty and returns.

Volume pricing

Buying 10+ units?

Get volume pricing and availability for GS752TPSB-100NAS.

Questions about this part?

Compatibility, condition, lead times — ask a specialist.

(888) 988-8093

Related products

Loading related inventory…