Home/Network & Accessories/Network Switches/EGS7228P - EnGenius 24-Port PoE+ Gigabit Layer 2 M...
EGS7228P - EnGenius 24-Port PoE+ Gigabit Layer 2 Managed Desktop Rack-Mountable Switch

Safe checkout

Secure payments

Fast dispatch

1–2 day handling

Free shipping

U.S. ground

Warranty & RMA

Support after delivery

EGS7228P - EnGenius 24-Port PoE+ Gigabit Layer 2 Managed Desktop Rack-Mountable Switch

SKU egs7228p
Brand EnGenius
  • Managed L2 Web-based management SNMP v1/2c/3
  • Quality of Service (QoS) support
  • Basic switching RJ-45 Ethernet ports quantity: 24 Console port: RJ-45
  • Switching capacity: 56 Gbit/s
  • Access Control List (ACL)
  • Rack mounting
  • Power over Ethernet (PoE)
Available to order

egs7228p isn't on our shelf today — we source it to order. Request a quote and we'll confirm price and lead time within one business day.

Key specifications

See full specs ↓
Switch type
Managed
Switch layer
L2
Quality of Service (QoS) support
Yes
Web-based management
Yes
MIB support
RFC1213, RFC1493, RFC1757, RFC2674
Basic switching RJ-45 Ethernet ports quantity
24

Product details

EnGenius EGS7228P. Switch type: Managed, Switch layer: L2. Basic switching RJ-45 Ethernet ports type: Gigabit Ethernet (10/100/1000), Basic switching RJ-45 Ethernet ports quantity: 24, Console port: RJ-45. Switching capacity: 56 Gbit/s. Networking standards: IEEE 802.1D, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ad, IEEE 802.3af, IEEE.... Power over Ethernet (PoE). Rack mounting

Management features

Switch typeManaged
Switch layerL2
Quality of Service (QoS) supportYes
Web-based managementYes
MIB supportRFC1213, RFC1493, RFC1757, RFC2674

Ports & interfaces

Basic switching RJ-45 Ethernet ports quantity24
Basic switching RJ-45 Ethernet ports typeGigabit Ethernet (10/100/1000)
SFP module slots quantity4
Console portRJ-45

Network

Networking standardsIEEE 802.1D, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3x
10G supportNo
Port mirroringYes
Broadcast storm controlYes
Spanning tree protocolYes
VLAN supportYes

Data transmission

Switching capacity56 Gbit/s
Store-and-forwardYes

Security

DHCP featuresDHCP client
Access Control List (ACL)Yes
IGMP snoopingYes
Static port securityYes

Protocols

Management protocolsSNMP v1/2c/3

Design

Rack mountingYes
Product colourBlack, Blue
LED indicatorsYes

Performance

Internal memory256 MB
Flash memory32 MB

Power over Ethernet (PoE)

Power over Ethernet (PoE)Yes
Power over Ethernet (PoE) ports quantity24
Total Power over Ethernet (PoE) budget185 W

Operational conditions

Operating temperature (T-T)0 - 50 °C
Storage temperature (T-T)-40 - 70 °C
Operating relative humidity (H-H)5 - 95%

Weight & dimensions

Width440 mm
Depth260 mm
Height44 mm

Packaging content

ManualYes

Description

Equipped with Rich Layer 2 Features The EnGenius Layer 2 switch includes IGMP Snooping, MLD Snooping, Port Mirroring, Rapid Spanning Tree, Multiple Spanning Tree, Spanning Tree, VLAN group, Voice VLAN, ACL, 802.1X port security, SNMP v1/v2c/v3 and IEEE802.3ad Link Aggregation Control Protocol (LACP). The EGS7228P includes 24 Gigabit PoE (10/100/1000 Mbps) ports and four SFP (copper/hot-swappable small form-factor pluggable) Gigabit ports for optional fiber connectivity. IT managers or VARs who are expanding network deployments for businesses, schools, resorts and hotels, or other expansive venues can expect superior performance and reliability at a price point that is much more attractive than from larger, more enterprise focused network brands. This high-performing switch also features a non-blocking wire-speed architecture with a 56 Gbps switching capacity for maximum data throughput. The IEEE 802.3x Flow Control function allows servers to directly connect to the switch for fast, reliable data transfer. Network maintenance features include Spanning Tree and Cable Diagnostics. Easy Network Management and Visibility This EnGenius Layer 2 Switch is designed for easy network management and can quickly be added to an existing rack of other branded L2 and L3 switches. Configuring the switch is made through an intuitive and user-friendly Web interface for quick and easy management. The EnGenius L2 switch also includes SNMP (v1, v2 and v3) to collect and track data to monitor network health, manage devices, and more easily enforce critical IT controls and policies. The switch’s Link Layer Discovery Protocol (LLDP) feature allows it and other network devices connected to it to announce and display their identity and capabilities on the local network, which helps IT managers better manage, troubleshoot or correct issues that may arise on the network. VLAN and Voice VLAN The EGS7228P provides support 802.1Q VLANs for improved convergence and bandwidth utilization. The switch automates the process of setting up VoIP devices on a network. Voice VLAN guarantees clear quality and efficient transmission for all voice communications. VLANs also provide a means of securing each broadcast domain, segregating them from each other. VLANs can be configured to segment departmental resources. VLANs implemented on an SMB network help to restrict access to sensitive information from one department to another. Multicast Support The EGS7228P supports IGMP Snooping, MLD Snooping, and VLAN for multicast applications. By passively snooping IGMP packets transferred between the switch and the IP multicast host, registration information is recorded and sorted into multicast groups. The switch can then intelligently forward traffic to only those ports that request multicast traffic. MLD Snooping enhances efficiency in selective distribution by forwarding IPv6 multicast data to receiving ports, rather than flooding all ports in a VLAN. IGMPv1—Defined in RFC 1112. An explicit join message is sent to the switch, but a timeout is used to determine when hosts leave a group. IGMPv2—Defined in RFC 2236. Adds an explicit leave message to the join message so that the switch can more easily determine when a group has no interested listeners on a LAN. IGMPv3—Defined in RFC 3376. Support for a single source of content for a multicast group. QoS for Smoother Video Conferences and Clearer Phone Calls Priority queueing ensures high-priority traffic gets delivered efficiently, even during congestion from high traffic bursts. The ability to prioritize traffic ensures quality of latency-sensitive services and applications despite increasing traffic loads. For mission critical environments, the EGS7228P supports 802.1D, 802.1w and 802.1s Spanning Tree Protocols (STP). STP allows you to configure the switch with a redundant backup bridge path, so transmission and reception of packets can be guaranteed in the event of any failed switch on the network. To help streamline networks, 802.1p Priority Tagging places a priority tag in a specified frame placing it in a priority queue once received and enabling it to be prioritized ahead of other frames. IEEE 802.1p enables administrators to assign and designate traffic priority. This process helps applications such as VoIP and video conferencing to be delivered clear and jitter-free. Making the Network More Secure The EGS7228P also supports 802.1X port-based authentication, so IT managers can authenticate clients via external RADIUS servers. In addition, the Access Control List (ACL) feature enhances network security and protects the network by screening traffic from unauthorized MAC or IP addresses. Energy Saving This EnGenius Layer 2 Switch is capable of conserving power without sacrificing operational performance. With the Energy Efficient Ethernet (EEE) standard, the network will automatically decrease its power usage when traffic is low with no setup required. The PoE Management feature lets IT managers control the PoE on each port so that unnecessary power consumption can be saved during off hours. The switch can also detect the length of connected cables to automatically reduce power usage on shorter cable connections. Power over Ethernet (PoE) With a total power budget of 185 Watts for the EGS7228P, customers can choose to plug in up to 24 802.3at/af IP-based devices. Power-over-Ethernet (PoE) optimizes the installation and power management of network devices such as wireless Access Points (APs), Voice over IP (VoIP) phones, and IP-based surveillance cameras. In addition, the EGS7228P’s Power-over- Ethernet (IEEE 802.3at/af) capabilities reduce installation time and costs for many new network productivity devices. Free your wireless AP deployments and IP cameras from the restrictions of power outlet proximity using a standard Cat 5 cable.

Condition: Refurbished

Free U.S. ground shipping

Typically 1–2 days handling, 3–7 days in transit.

Purchase orders accepted

Government, enterprise, data center and small business.

Warranty & RMA support

See warranty and returns.

Buying 10+ units?

Get volume pricing and availability for egs7228p.

Questions about this part?

Compatibility, condition, lead times — ask a specialist.

(888) 988-8093

Related products

Loading related inventory…