Home/Network & Accessories/Network Switches/Allied AT-X510L-28GT-50 Telesis x510 24-Port 4x SF...
Allied AT-X510L-28GT-50 Telesis x510 24-Port 4x SFP+ Switch

Allied AT-X510L-28GT-50 Telesis x510 24-Port 4x SFP+ Switch

SKU AT-X510L-28GT-50
Allied TelesisShop all Allied Telesis parts (589) ›
  • Managed L3 Web-based management SNMP, MLD
  • Quality of Service (QoS) support
  • Basic switching RJ-45 Ethernet ports quantity: 24 Console port: RJ-45
  • 1U Rack mounting
Available to order

AT-X510L-28GT-50 isn't on our shelf today — we source it to order. Request a quote and we'll confirm price and lead time within one business day.

Key specifications

See full specs ↓
Switch type
Managed
Switch layer
L3
Quality of Service (QoS) support
Yes
Web-based management
Yes
System event log
Yes
MIB support
RFC1212, RFC1213, RFC1227, RFC1239, RFC1724, RFC2011, RFC2012, RFC2013, RFC2096, RFC3418, RFC3621, RFC3636, RFC2819, RFC2863

Product details

Allied Telesis AT-x510L-28GT-50. Switch type: Managed, Switch layer: L3. Basic switching RJ-45 Ethernet ports type: Gigabit Ethernet (10/100/1000), Basic switching RJ-45 Ethernet ports quantity: 24, Console port: RJ-45. Full duplex. MAC address table: 16000 entries, Switching capacity: 128 Gbit/s. Networking standards: IEEE 802.2, IEEE 802.3, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3ae, IEEE 802.3af, IEEE 802.3at, IEEE.... Power connector: DC-in jack. Rack mounting, Form factor: 1U

Specifications

Switch type
Managed
Switch layer
L3
Quality of Service (QoS) support
Yes
Web-based management
Yes
System event log
Yes
MIB support
RFC1212, RFC1213, RFC1227, RFC1239, RFC1724, RFC2011, RFC2012, RFC2013, RFC2096, RFC3418, RFC3621, RFC3636, RFC2819, RFC2863
Basic switching RJ-45 Ethernet ports quantity
24
Basic switching RJ-45 Ethernet ports type
Gigabit Ethernet (10/100/1000)
SFP+ module slots quantity
4
Console port
RJ-45
Power connector
DC-in jack
Networking standards
IEEE 802.2, IEEE 802.3, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3ae, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z
10G support
No
Port mirroring
Yes
Full duplex
Yes
Flow control support
Yes
Link aggregation
Yes
Broadcast storm control
Yes
Spanning tree protocol
Yes
VLAN support
Yes
Number of VLANs
4094
Switching capacity
128 Gbit/s
Throughput
95.2 Mpps
MAC address table
16000 entries
Latency (10-100 Mbps)
14.4 µs
Latency (1 Gbps)
4.4 µs
Latency (10 Gbps)
3.1 µs
Jumbo frames support
Yes
DHCP features
DHCP server, DHCP client
IGMP snooping
Yes
Security algorithms
EAP-TTLS, MD5, PEAP, SSL/TLS
Multicast support
Yes
Management protocols
SNMP, MLD
Data link protocols
LLDP
Supported network protocols
IGMP
Rack mounting
Yes
Form factor
1U
Product colour
Grey
LED indicators
Yes
Safety
UL60950-1, CAN/CSA-C22.2 No. 60950-1-03, EN60950-1, EN60825-1, AS/NZS 60950.1
Power consumption (typical)
52 W
Power over Ethernet (PoE)
No
Operating temperature (T-T)
0 - 45 °C
Storage temperature (T-T)
-25 - 70 °C
Operating relative humidity (H-H)
5 - 90%
Storage relative humidity (H-H)
5 - 95%
Operating altitude
0 - 3048 m
Heat dissipation
177 BTU/h
Width
440 mm
Depth
325 mm
Height
44 mm
Certification
UL, cUL, TUV

Description

The high-value Allied Telesis AT-x510L-28GT Gigabit edge switch features 24 x 10/100/1000T ports and 4 x 1G/10G SFP+ uplink ports with a single internal power supply. The x510L Series offers cost-effective edge connectivity for healthcare, education, and government applications. Comprehensive security and access features protect online resources, while the ability to upgrade the uplink speed and feature-set ensure a future-proof solution.

Condition: Refurbished

Free U.S. ground shipping

Typically 1–2 days handling, 3–7 days in transit.

Purchase orders accepted

Government, enterprise, data center and small business.

Warranty & RMA support

See warranty and returns.

Volume pricing

Buying 10+ units?

Get volume pricing and availability for AT-X510L-28GT-50.

Questions about this part?

Compatibility, condition, lead times — ask a specialist.

(888) 988-8093

Related products

Loading related inventory…